Knowledge Base .: 0610 Cardex Upgrade Error: Could not load file or assembly System.EnterpriseServices.wrapper.dll...could not find the path specified

0610 Cardex Upgrade Error: Could not load file or assembly System.EnterpriseServices.wrapper.dll...could not find the path specified

SYMPTOM

When you open the Cardex database, an error appears: "Cardex Upgrade Error: Could not load file or assembly System.EnterpriseSerices, Version=2.0.0.0...or one of its dependencies. The system cannot find the path specified..."

CAUSE

  • Appstream Technologies and Encompass is installed causing the Cardex error.
  • Microsoft .NET Framework 2.0 is missing components.

RESOLUTION

Uninstall Appstream Windows Edition 5.2.2 (Note: you will need to reinstall Encompass)

  1. Go to the Control Panel.
  2. Double-click Add/Remove Programs.
  3. Select AppStream Technology Windows Edition 5.2.2 - Client.
  4. Click Remove.


  5. When it has been uninstalled, restart the computer.
  6. Open Point and access the Cardex Database.

Uninstall/Reinstall Microsoft .NET Framework

  1. Go to the Control Panel.


    • For Windows XP: Double-click Add/Remove Programs
    • For Windows Vista/7: Double-click Programs and Features

  2. Uninstall all versions of Mirosoft .NET Framework.
  3. When the above Microsoft .Net applications have been successfully removed, restart the computer.
  4. Once the computer has been restarted, click here to download and install Microsoft .NET Framework 3.5SP1.
  5. Open Point to see if the error is resolved.

If you are unable to uninstall Microsoft .NET Framework or the above steps did not work, complete the following steps:

  1. Uninstall all versions of Microsoft.NET Framework from the Add/Remove Programs or Programs and Features list in the Control Panel.
  2. Restart the computer.
  3. Click here to download the Microsoft .NET Framework cleanup utility.
  4. From the Installation Cleanup Utility, select .NET Framework (All Versions) from the Product to cleanup dropdown list.
  5. Click Clean up Now.
  6. Wait for the Current Status to change to "Setup has completed".
  7. Click Exit and then restart the computer.


  8. When the computer has restarted:

    • (For Windows XP): click here to install Microsoft .NET Framework 3.5 SP1.
    • (For Windows 7): Microsoft.NET Framework 3.5 can be installed by going to the Control Panel > Programs and Features > Turn Windows Features on or off > check all 3 boxes for Microsoft .NET Framework and then click OK.

  9. When Microsoft .NET Framework 3.5 SP1 has finished, restart the computer.
  10. Try opening Point again.


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