Knowledge Base .: 0285 Error: Printer not activated. Code -20, -30, -41

0285 Error: Printer not activated. Code -20, -30, -41

SYMPTOM

When you generate a custom form as a .PDF document, an error occurs: "Error Code -20, -30, or -40. Printer not activated."

CAUSE

  • Antivirus scripts are blocking Point from generating the document
  • You do not have appropriate permissions to use the Calyx Document Converter.
  • There is printer software installed causing a conflict

RESOLUTION

Reinstall the Calyx Document Converter

*Note: Quickbooks pdf driver tends to conflict with the Point pdf driver. If Quickbooks is installed this is likely the solution for it.

  1. Close Point.
  2. Restart the computer.
  3. When the computer has restarted, go to My Computer.
  4. Double-click Local Disk (C:).
  5. Double-click the Winpoint folder.
  6. Double-click the PDFInstall.exe file. Nothing will happen, but once you double-click on the file, it takes about 1 minute for it to reinstall the pdf converter for Point.
  7. Open Point and try to email a form again.

The Office Plug-In feature in Norton Antivirus is preventing Point from generating the Custom Form as a .PDF

  1. Close Point.
  2. Open Norton Antivirus.
  3. Click Options or Other.
  4. Click Miscellaneous.
  5. Uncheck the Office Plug-In box and click OK.
  6. Open Point.
  7. E-mail or save a custom form.

Note* If the above resolution does not resolve the issue or you do not have Norton Antivirus installed, disable script blocking in the antivirus software that is installed.

 

Delete all versions of the Amyuni driver files and reinstall the Calyx Document Converter

  1. Restart the computer.
  2. Go to the Control Panel.
  3. Double-click Printers & Faxes.
  4. Delete the following printers if they exist:
    • Amyuni Document Converter
    • Calyx Document Converter
  5. Double-click My Computer.
  6. Double-click Local Disk (C:).
  7. Double-click the WINDOWS folder. (For 32-bit operating systems, double-click the System32 folder. (For 64-bit operating systems, double-click the SYSWOW64 folder).
  8. Delete the following files if they exist:
    • acpdfcrext.dll
    • cdintf.dll
    • cdintf210.dll
    • cdintf250.dll
    • cdintf300.dll
    • cdintf450.dll
    • cdintf450_64.dll
  9. Go to My Computer > Local Disk (C:).
  10. Double-click the Windows folder and open the System32 folder.
  11. Double-click the spool folder.
  12. Double-click the drivers folder.
  13. Double-click the w32x86 folder.
  14. Delete the following files if they exist:
    • acfpdf.txt
    • acfpdf207.dll
    • acfpdf210.dll
    • acfpdf250.dll
    • acpdf300.dll
    • acpdfui300.dll
    • acpdfui207.dll
    • acpdfui210.dll
    • acpdfui250.dll
    • pdfui250.dll
  15. Double click the 2 folder.
  16. Delete the following files if they exist:
    • acfpdf.txt
    • acfpdf207.dll
    • acfpdf210.dll
    • acfpdf250.dll
    • acpdf300.dll
    • acpdfui300.dll
    • acpdfui207.dll
    • acpdfui210.dll
    • acpdfui250.dll
    • pdfui250.dll
  17. Go back to the w32x86 folder.
  18. Double click the 3 folder.
  19. Delete the following files if they exist:
    • acfpdf.txt
    • acfpdf207.dll
    • acfpdf210.dll
    • acfpdf250.dll
    • acpdf300.dll
    • acpdf450.dll
    • acpdfui300.dll
    • acpdfui207.dll
    • acpdfui210.dll
    • acpdfui250.dll
    • acpdfui450.dll
    • pdfui250.dll
  20. When all the above files have been successfully deleted, Go to My Computer
  21. Double-click Local Disk (C:) drive.
  22. Open the Winpoint folder and then double-click PDFInstall.exe. (This will re-install the Calyx Document Converter)
  23. Close the Windows Explorer window and then go to the Control Panel.
  24. Double-click Printers & Faxes.
  25. Right click the Calyx Document Converter printer and select Properties or Printer Properties.
  26. From the Properties window, click the Ports tab.
  27. Click Add Port.




  28. From the Printer Ports window, select Local Port.
  29. Click New Port.


  30. From the Port Name window, enter CLX and then click OK.

  31. Click Close from the Printer Ports Window.
  32. From the printer properties window, click Apply.
  33. Click the Security tab.
  34. Click Add.


  35. From the Select or Groups window - click Locations.


  36. From the Locations window, select the local computer name. (It should be the first computer name in the list).
  37. Click OK.


  38. From the Select Users or Groups window, click Advanced.


  39. From the Select Users or Groups window, click Find Now.
  40. From the Search Results, locate and double-click Users.
  41. Click OK.


  42. From the Calyx Document Converter Properties window, select Users in the Group or user names section.
  43. Insert a check under the Allow column for Print, Manage this printer, and Manage documents.


  44. Click OK.
  45. Open Point and try again.

There is printer software installed causing a conflict with the Calyx Document Converter. (Such as, HP software or Deskjet Series software)

  1. Close Point.
  2. From the desktop, select Start > Run.
  3. In the Open field, enter taskmgr and then click OK.
  4. From the Task Manager window, click the processes tab.
  5. Look for any process that beings with Hp...
  6. Highlight it and click End Process.


  7. When all HP processes have been ended, open Point and try to e-mail a form.

    • You can also disable printer software from starting by clicking Start > Run.
    • In the Open field, enter msconfig and then click OK.
    • From the System Configuration Utility window, select the Startup tab.
    • Uncheck any printer software that may be set to start automatically. Hp printer software usually begins with hp... Also uncheck any other software that might conflict with the driver, such as antivirus.
    • Click OK and then restart the computer.


  8. If selecting disabling some of the startup programs resolves the error. Then one of them is causing a conflict.


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